STM32 Дисплей на RM68140, не могу запустить.

Эдуард Анисимов

★★★★★✩✩
23 Сен 2019
1,409
493
55
Марий-Эл
Ситуёвина такая.
Есть дисплей 3.5" с контроллером RM68140.
Проблема в следующем.
Провожу инициализацию. На дисплее появляется мусор, который находится в памяти.
Когда пытаюсь задать координаты окна вывода, экран становится серым и заполнение экрана каким либо цветом не производится.
Косил на то, что неправильно подключил. Но, до заливки, пробую инвертировать экран. Получается.

Пробовал сам его программировать, не работает. Передирал библиотеку MCUFRIEND_kbv, не работает.
Подключение 8ми битное.

Может кто нибудь знает в чём проблема?
В инете инфы никакой.
 

Дон

✩✩✩✩✩✩✩
3 Май 2021
2
0
Эдуард привет

Напряжение питания для 3.5" ЖК дисплей на RM68140 имеет уровень Vcc=3,3 Вольт, и не может напрямую подключаться к любой плате с напряжением питания Vcc= 5 Вольт. Вот сборка для контроллеров: RM68140, R61581, ILI9488 и HX8357B. (6 метров).
Успехов

эыж: загрузить не получается ! вот ссылка
 
Последнее редактирование:

Эдуард Анисимов

★★★★★✩✩
23 Сен 2019
1,409
493
55
Марий-Эл
Я не понял сути вашего ответа.
Дисплей у меня есть.
Под ардуиной я его запустил.
Я собрал плату на STM а там хочешь нехочешь больше 3.3 вольт не будет.
Дело не неправильности подключения или командах.
Я уже забросил его. Сделал на другом дисплее. Побольше размером.
А в этом случае я думаю, что ему не хватает тока. Так как я питал его через программатор.
Узнал поздно, что именно этот программатор с каким то глюком и даёт малый ток.