Ошибка отправки nRF24L01.

kostyamat

Проходящий мимо
29.10.2019
206
93
33
#21
Да, я с вами согласен, но все от напряжения до чипа в порядке.
Да как же в порядке то, если у вас все прочитанные (или таки непрочитанные?) регистры в ноль или FF? Судя по вашему же скрыну с инфо по чипу. Это первое, что говорит - пациент скорее мертв, чем жив? Проверяйте соединения пин в пин, выбросьте переходники, посмотрите дефайны в скетче - те ли ноги используются, что припаяны у вас.

Вот так, приблизительно, должны отображаться регистры, не обязательно в точности, но не в 0, все. ;)
 

Вложения

Последнее редактирование:

kostyamat

Проходящий мимо
29.10.2019
206
93
33
#22
А ещё, бывают фейковые чипы (а есть ещё клоны, которые работают, но дерьмово или странно), я уже писал, регистры читаются, а связи нет. Эфир сканируется вроде, но выглядит абсолютно чистым, так не бывает. Купил другие - заработало сразу (не обязательно ваш случай, просто предупреждаю).
 
30.03.2019
18
0
1
#23
Ну я про напряжение и радиодетали говорил. А как выглядит рабочий вариант я знаю (один из двух переходников рабочий, но он к уно припаян). С нерабочем переходником модуль выдает, все каналы засраны.
 
13.02.2020
147
22
18
Харьков
#24
@Fendragon, тогда предложу ещё вариант. Попробуйте убрать переходник, ведь в нём только стабилизатор 3,3В, да конденсаторы фильтра. Подайте на nrf те же 3,3В с какого-нибудь блока питания с выходным током не менее 1А. Ну и о фильтрации питающего напряжения не забывайте, навесьте фильтрующие конденсаторы прямо на nrf.
 
Последнее редактирование:
30.03.2019
18
0
1
#25
Перепробовал все что вы советовали (подключал отдельно питание 3.3В, амперметр вообще никаких токов не зафиксировал ), но все равно не заработал.