ARDUINO WL102-431 и SIM800L

Санче

✩✩✩✩✩✩✩
26 Фев 2020
4
0
Добрый день, подключил к ардуино WL102-431 и SIM800L по радио команды отправляются а SIM800L перестает работать.
 

PiratFox

★★★✩✩✩✩
13 Фев 2020
530
114
Харьков
@Санче, первое, что приходит на ум - электромагнитная несовместимость модулей. WL102-431 вообще проблемный радиомодуль. А тут ещё его 2-я гармоника налезает на GSM диапазон. Похоже, именно ней (гармоникой) душится приёмник SIM800L, и он теряет связь с мобильной сетью. Выход здесь один: вместо WL102-431 применить другой радиомодуль на другую частоту. Скажем, nRF24L01. Ещё вариант - дохленький источник питания, всё сразу не тянет.
 
Последнее редактирование:

Санче

✩✩✩✩✩✩✩
26 Фев 2020
4
0
Ну подключено питание от подключения к компу, а SIM800L отдельно подключено на 5в 2.5Ам , пробовал в скетче только отключаю WL начинает работать, подключаю в скетче ультрозвуковой дальномер HC-SR04 опять перестает работать, хотя все модули подключены именно когда скетч меняю меняю начинается. Наверное включаются когда доп приборы на SIM800L помехи идут? ни кто не встречался с таким?
 

PiratFox

★★★✩✩✩✩
13 Фев 2020
530
114
Харьков
@Санче, Вы сами ответили на вопрос. Проблема в радиомодуле. Я жеж говорю: гемморойный он. Гармоники, собака, вешает вокруг себя.
 

PiratFox

★★★✩✩✩✩
13 Фев 2020
530
114
Харьков
Да я ведь не про GSM SIM800L. С ним-то всё нормально. Геморрой у Вас, я так понял, начинается при включении WL102-431. Вот это и есть причина всех бед. Или я что-то не так понимаю?
 

Санче

✩✩✩✩✩✩✩
26 Фев 2020
4
0
я когда подключаю ультрозвуковой дальномер HC-SR04 , GSM SIM800L модуль опять перестает работать