Проблемы с Arduino WavGat UNO3

Роман_71

✩✩✩✩✩✩✩
5 Фев 2019
6
0
Разбираюсь с Arduino WavGat UNO3. Купил по ссылке с сайта alexGyver. https://www.aliexpress.com/item/hig...O-R3-USB-CABLE-ATMEGA328P-AU/32810623079.html
На данной плате установлен Китайский МК LGT8F328.Разобрался c заливкой скетчей через Arduino ID, но имеется один момент. Напряжение на цифровых пинах и ШИМ равно 3.3 В. У Arduino WavGat NANO https://www.aliexpress.com/item/1PC...Module-PCB-Development-Board/32531372300.html от того же производителя, с напряжением все нормально. В чем косяк? Брак платы или 5 В можно поднять программно?
 

Wan-Derer

★★★★★✩✩
Команда форума
31 Июл 2018
1,470
301
Москва
wan-derer.ru
@Роман_71, Н-да, по Уно надо спор открывать. В наименовании чётко сказано что Атмега, да и в описании - неоднозначно как-то. Если 2 недели не прошло, открывай спор с резоном "Контрафакт". Надо дрочить этих уродов...
Что касается вопроса, то хрен его знает как оно должно работать. Скорее всего, 5В д.б. Надо вымерять какие там на плате напряжения. Может они стаб 3-вольтовый воткнули вместо 5-вольтового. Или залипуха где.
 

Роман_71

✩✩✩✩✩✩✩
5 Фев 2019
6
0
int pin_digital_1 = 9;
int pin_digital_2 = 10;
int pin_digital_3 = 11;
byte N = 0;
unsigned long time_1=0;
int delay_ = 50;

void setup() {
pinMode(pin_digital_1, OUTPUT);
pinMode(pin_digital_2, OUTPUT);
pinMode(pin_digital_3, OUTPUT);
pinMode(13, OUTPUT);
}

void loop() {
if (millis()-time_1>=delay_)
{
if (N==0)
{
digitalWrite(13, 1);
digitalWrite(pin_digital_1, 1);
digitalWrite(pin_digital_2, 1);
digitalWrite(pin_digital_3, 1);
N = 1;
time_1=millis();
}
else
{
digitalWrite(13, 0);
digitalWrite(pin_digital_1, 0);
digitalWrite(pin_digital_2, 0);
digitalWrite(pin_digital_3, 0);
N = 0;
time_1=millis();
}
}
}
 

Вложения

Роман_71

✩✩✩✩✩✩✩
5 Фев 2019
6
0
Открыл спор с продавцом, спор закрыт, решение возврат денег. Правда стоит плата копейки. Но все же.
 

abo96

✩✩✩✩✩✩✩
16 Фев 2019
6
0
а у меня этот wawgatи вообше норм неработают монитор порта показывают толко кубики и икси болше нечего
 

Роман_71

✩✩✩✩✩✩✩
5 Фев 2019
6
0
Плата в общем рабочая. Сейчас экспериментирую с ней. А насчет кубиков, в Arduino ID загружал вот такую ерунду? https://drive.google.com/open?id=10gwrG9uTDwaEO-7EudsmBkfgdcyrcABI. И скорость порта в скетче и мониторе порта должны совпадать.
 

Вложения

Юрий Пустовой

✩✩✩✩✩✩✩
1 Дек 2019
3
1
Кто нибудт пользовал эту штуку с MultiFunctional Shield?
У меня бипер орет постоянно. по питанию просечки до 15 в...
 

Юрий Пустовой

✩✩✩✩✩✩✩
1 Дек 2019
3
1
спасибо. эта штука позволила пофиксить неработу индикатора, но писк остался. возбуд пропадает гдето около 6 вольт по питанию. если давать 5 или так как написано на плате (7+) то будится и никакие кондеры не спасают.

А библиотека сделана похабно: у них на 4 ноге цап, и они тупо запрещают вывод по этой ноге... Китайцы, блин.