Проблема с точечной матрицей

martynmd

✩✩✩✩✩✩✩
17 Апр 2020
2
0
Всем привет! Получил точечную матрицу с Али на основе max7219 и зелёными светодиодами. В чём состоит проблема: для ознакомления решил посмотреть несколько туториалов по данной матрице на YouTube. Повторил - светодиоды работают, но дилемма в том, что при аналогичных параметрах в коде, в видео всё работает без нареканий, а у меня, при достижении определённого количества зажжённых светодиодов, Ардуино отключается от компьютера и потом ведёт себя абсолютно рандомно. Иногда назад подключается, а иногда нет - и так по кругу. Проблема исчезает, если понизить яркость или отключить GND - тогда работает всё корректно: текст бежит как надо, но тускло. Пробовал другие библиотеки - та же фигня. Есть мысли, что либо сама матрица бракованная, либо есть неполадка с питанием, но ничего конкретного. Так что прошу более опытных подсказать, что же может быть причинной такового поведения.

Видео о подключении

Фото:
20200417_122030.jpg20200417_122058.jpg


При таком количестве светодиодов на средне-высокой яркости хватает, чтобы Ардуино самопроизвольно отключалась от ПК.
20200417_124428.jpg
 

martynmd

✩✩✩✩✩✩✩
17 Апр 2020
2
0
Не знаю почему, но я никаким образом не обращал внимание на datasheet конкретно светодиодной матрицы - даже как-то обидно за такой протуп. Выходит, что один потребляет около 25 мА в адекватном режиме работы, и Ардуино не вывозит по питанию большое их кол-во. Благодарю за ответ :)
 

kalobyte

★★★✩✩✩✩
1 Янв 2020
725
145
не все порты тянут этот ток
мой роутер не тянет 2.5" диск, а компутер тянет
плата уно питается напрямую от усб
стабилизатор там работает только если плата запитана от внешнего источника выше 5в